Well, I THOUGHT I was ready…

Posted: January 12, 2012 in Uncategorized

Be careful what you wish for.  Yesterday, I worked on the truck all day.  Got the plow mounted and wired, put gas in the truck, drove it to Delton, no problems.   Let it snow, I believe I said.  

 This morning I got in and went over to Dads to finish up a couple of things and modify the skid pad mounts (they held the blade too far off the ground), and was greeted by a green waterfall from the front of the truck when I got there.  I’ve already replaced the radiator hoses, clamps, and fan belts, so I figured it couldn’t be good.

I pulled the radiator and took it to my friend Bud’s radiator shop (Kings Radiator, in Kalamazoo, if you need radiator help!), and had a hunch it might be bad when he looked and said, “Whoa, that’s one of those big expensive ones.”

I left it, and by the time I got  home there was a message.   Indeed, as I feared, the core is so badly corroded it’s not repairable.  Happily, he had a NOS 4 row core on the shelf, and is cutting me a deal.  It’ll be ready tomorrow, so if we’re not snowed in, I’ll get it put back together.  I’ll owe him a driveway plow or two!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s